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This user guide describes how to use the National Instruments
USB-6008/6009 data acquisition (DAQ) devices and lists specifications.

Introduction
The NI USB-6008/6009 provides connection to eight analog input (AI)
channels, two analog output (AO) channels, 12 digital input/output (DIO)
channels, and a 32-bit counter with a Full-Speed USB interface.
This manual revision updates naming conventions to reflect the conventions used in
NI-DAQmx. Table 1 notes the correlation between the old and updated names.

Note

Table 1. Digital Output Driver Type Naming Conventions

Hardware Functionality

NI-DAQmx Terminology

Open-drain

Open collector

Push-pull

Active drive

Table 2. Differences Between the NI USB-6008 and NI USB-6009

Feature

NI USB-6008

NI USB-6009

12 bits differential,
11 bits single-ended

14 bits differential,
13 bits single-ended

Maximum AI Sample Rate,
Single Channel*

10 kS/s

48 kS/s

Maximum AI Sample Rate,
Multiple Channels (Aggregate)*

10 kS/s

48 kS/s

Open collector

Open collector or active drive

AI Resolution

DIO Configuration
*

System dependent.

1

17

1

Digital

Analog

NI USB-6009
16

1

32

8 Inputs, 14-bit, Multifunction I/O

USB Cable Strain Relief

Figure 1. NI USB-6008/6009 Top View

Figure 2. NI USB-6008/6009 Back View
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Dimensions
Figure 3 illustrates the dimensions of the NI USB-6008/6009 device.

23.19 mm
(0.913 in.)

81.81 mm
(3.221 in.)

85.09 mm
(3.350 in.)
NATIONAL
INSTRUMENTS

76.09 mm
(2.996 in.)

63.50 mm
(2.500 in.)
72.65 mm
(2.860 in.)

Figure 3. NI USB-6008/6009 in Millimeters (Inches)

Safety Guidelines
Caution

Operate the NI USB-6008/6009 only as described in these operating instructions.
The following section contains important safety information that you must
follow when installing and using the NI USB-6008/6009.

Caution Do not operate the NI USB-6008/6009 in a manner not specified in this
document. Misuse of the device can result in a hazard. You can compromise the safety
protection built into the device if the device is damaged in any way. If the device is
damaged, contact National Instruments for repair.

Do not substitute parts or modify the device except as described in this document.
Use the device only with the chassis, modules, accessories, and cables specified in the
installation instructions. You must have all covers and filler panels installed during
operation of the device.

Caution

© National Instruments Corporation
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Do not operate the device in an explosive atmosphere or where there may be
flammable gases or fumes. If you must operate the device in such an environment, it must
be in a suitably rated enclosure.

Caution

If you need to clean the device, use a dry cloth. Make sure that the device
is completely dry and free from contaminants before returning it to service.
Operate the device only at or below Pollution Degree 2. Pollution is foreign
matter in a solid, liquid, or gaseous state that can reduce dielectric strength
or surface resistivity. The following is a description of pollution degrees:
•

Pollution Degree 1 means no pollution or only dry, nonconductive
pollution occurs. The pollution has no influence.

•

Pollution Degree 2 means that only nonconductive pollution occurs in
most cases. Occasionally, however, a temporary conductivity caused
by condensation must be expected.

•

Pollution Degree 3 means that conductive pollution occurs, or dry,
nonconductive pollution occurs that becomes conductive due to
condensation.

You must insulate signal connections for the maximum voltage for which
the device is rated. Do not exceed the maximum ratings for the device. Do
not install wiring while the device is live with electrical signals. Do not
remove or add connector blocks when power is connected to the system.
Avoid contact between your body and the connector block signal when hot
swapping modules. Remove power from signal lines before connecting
them to or disconnecting them from the device.
Operate the device at or below the Measurement Category I1. Measurement
circuits are subjected to working voltages2 and transient stresses
(overvoltage) from the circuit to which they are connected during
measurement or test. Measurement categories establish standard impulse
withstand voltage levels that commonly occur in electrical distribution
systems. The following is a description of measurement categories:
•

1

2
3

Measurement Category I is for measurements performed on circuits
not directly connected to the electrical distribution system referred to
as MAINS3 voltage. This category is for measurements of voltages
from specially protected secondary circuits. Such voltage
measurements include signal levels, special equipment, limited-energy
parts of equipment, circuits powered by regulated low-voltage sources,
and electronics.

Measurement Category as defined in electrical safety standard IEC 61010-1. Measurement Category is also referred to as
Installation Category.
Working Voltage is the highest rms value of an AC or DC voltage that can occur across any particular insulation.
MAINS is defined as a hazardous live electrical supply system that powers equipment. Suitably rated measuring circuits may
be connected to the MAINS for measuring purposes.
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•

Measurement Category II is for measurements performed on circuits
directly connected to the electrical distribution system. This category
refers to local-level electrical distribution, such as that provided by a
standard wall outlet (for example, 115 V for U.S. or 230 V for Europe).
Examples of Measurement Category II are measurements performed
on household appliances, portable tools, and similar E Series devices.

•

Measurement Category III is for measurements performed in the
building installation at the distribution level. This category refers to
measurements on hard-wired equipment such as equipment in fixed
installations, distribution boards, and circuit breakers. Other examples
are wiring, including cables, bus-bars, junction boxes, switches,
socket-outlets in the fixed installation, and stationary motors with
permanent connections to fixed installations.

•

Measurement Category IV is for measurements performed at the
primary electrical supply installation (<1,000 V). Examples include
electricity meters and measurements on primary overcurrent
protection devices and on ripple control units.

Related Documentation
Each application software package and driver includes information about
writing applications for taking measurements and controlling measurement
devices. The following references to documents assume you have
NI-DAQmx 8.7 or later, and where applicable, version 7.1 or later of the
NI application software.

NI-DAQmx for Windows
The DAQ Getting Started Guide describes how to install your NI-DAQmx
for Windows software, how to install your NI-DAQmx-supported DAQ
device, and how to confirm that your device is operating properly. Select
Start»All Programs»National Instruments»NI-DAQ»DAQ Getting
Started Guide.
The NI-DAQ Readme lists which devices are supported by this version of
NI-DAQ. Select Start»All Programs»National Instruments»NI-DAQ»
NI-DAQ Readme.
The NI-DAQmx Help contains general information about measurement
concepts, key NI-DAQmx concepts, and common applications that are
applicable to all programming environments. Select Start»All Programs»
National Instruments»NI-DAQ»NI-DAQmx Help.
Note For information about non-Windows operating system support, refer to ni.com/
info and enter BaseGSGML.
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LabVIEW
If you are a new user, use the Getting Started with LabVIEW manual
to familiarize yourself with the LabVIEW graphical programming
environment and the basic LabVIEW features you use to build data
acquisition and instrument control applications. Open the Getting Started
with LabVIEW manual by selecting Start»All Programs»National
Instruments»LabVIEW»LabVIEW Manuals or by navigating to the
labview\manuals directory and opening LV_Getting_Started.pdf.
Use the LabVIEW Help, available by selecting Help»Search the
LabVIEW Help in LabVIEW, to access information about LabVIEW
programming concepts, step-by-step instructions for using LabVIEW, and
reference information about LabVIEW VIs, functions, palettes, menus, and
tools. Refer to the following locations on the Contents tab of the LabVIEW
Help for information about NI-DAQmx:
•

Getting Started»Getting Started with DAQ—Includes overview
information and a tutorial to learn how to take an NI-DAQmx
measurement in LabVIEW using the DAQ Assistant.

•

VI and Function Reference»Measurement I/O VIs and
Functions—Describes the LabVIEW NI-DAQmx VIs and properties.

•

Taking Measurements—Contains the conceptual and how-to
information you need to acquire and analyze measurement data in
LabVIEW, including common measurements, measurement
fundamentals, NI-DAQmx key concepts, and device considerations.

LabWindows/CVI
The Data Acquisition book of the LabWindows/CVI Help contains
measurement concepts for NI-DAQmx. This book also contains
Taking an NI-DAQmx Measurement in LabWindows/CVI, which includes
step-by-step instructions about creating a measurement task using the DAQ
Assistant. In LabWindows™/CVI™, select Help»Contents, then select
Using LabWindows/CVI»Data Acquisition.
The NI-DAQmx Library book of the LabWindows/CVI Help contains
API overviews and function reference for NI-DAQmx. Select Library
Reference»NI-DAQmx Library in the LabWindows/CVI Help.

Measurement Studio
If you program your NI-DAQmx-supported device in Measurement Studio
using Visual C++, Visual C#, or Visual Basic .NET, you can interactively
create channels and tasks by launching the DAQ Assistant from MAX or
from within Visual Studio .NET. You can generate the configuration code
based on your task or channel in Measurement Studio. Refer to the DAQ
Assistant Help for additional information about generating code. You also
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can create channels and tasks, and write your own applications in your
ADE using the NI-DAQmx API.
For help with NI-DAQmx methods and properties, refer to the NI-DAQmx
.NET Class Library or the NI-DAQmx Visual C++ Class Library included
in the NI Measurement Studio Help. For general help with programming in
Measurement Studio, refer to the NI Measurement Studio Help, which is
integrated with the Microsoft Visual Studio .NET help. To view this
help file in Visual Studio. NET, select Measurement Studio»
NI Measurement Studio Help.
To create an application in Visual C++, Visual C#, or Visual Basic .NET,
follow these general steps:
1.

In Visual Studio .NET, select File»New»Project to launch the New
Project dialog box.

2.

Find the Measurement Studio folder for the language you want to
create a program in.

3.

Choose a project type. You add DAQ tasks as a part of this step.

ANSI C without NI Application Software
The NI-DAQmx Help contains API overviews and general information
about measurement concepts. Select Start»All Programs»National
Instruments»NI-DAQ»NI-DAQmx Help.
The NI-DAQmx C Reference Help describes the NI-DAQmx Library
functions, which you can use with National Instruments data acquisition
devices to develop instrumentation, acquisition, and control applications.
Select Start»All Programs»National Instruments»NI-DAQ»
NI-DAQmx C Reference Help.

.NET Languages without NI Application Software
With the Microsoft .NET Framework version 1.1 or later, you can use
NI-DAQmx to create applications using Visual C# and Visual Basic
.NET without Measurement Studio. You need Microsoft Visual Studio
.NET 2003 or Microsoft Visual Studio 2005 for the API documentation
to be installed.
The installed documentation contains the NI-DAQmx API overview,
measurement tasks and concepts, and function reference. This help is
integrated into the Visual Studio .NET documentation. To view the
NI-DAQmx .NET documentation, go to Start»All Programs»National
Instruments»NI-DAQ»NI-DAQmx .NET Reference Help. Expand
NI Measurement Studio Help»NI Measurement Studio .NET Class
Library»Reference to view the function reference. Expand
NI Measurement Studio Help»NI Measurement Studio .NET Class
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Library»Using the Measurement Studio .NET Class Libraries to
view conceptual topics for using NI-DAQmx with Visual C# and
Visual Basic .NET.
To get to the same help topics from within Visual Studio, go to
Help»Contents. Select Measurement Studio from the Filtered By
drop-down list and follow the previous instructions.

Device Documentation and Specifications
Documentation for supported devices and accessories, including PDF
and help files describing device terminals, specifications, features, and
operation are on the NI-DAQmx CD that includes Device Documentation.
Insert the CD, open the Device Documentation directory, and double-click
the Device Documents shortcut for your language to find, view, and print
device documents.
Note

You can also download these documents at ni.com/manuals.

NI-DAQmx Base (Linux/Mac OS X/LabVIEW PDA 8.x)
The NI-DAQmx Base Getting Started Guide describes how to install your
NI-DAQmx Base software, your NI-DAQmx Base-supported DAQ device,
and how to confirm that your device is operating properly. In Windows,
select Start»All Programs»National Instruments»NI-DAQmx Base»
Documentation»NI-DAQmx Base Getting Started Guide.
Getting Started with NI-DAQmx Base for Linux and Mac Users describes
how to install your NI-DAQmx Base software, your NI-DAQmx
Base-supported DAQ device, and how to confirm that your device is
operating properly on your Mac/Linux machine.
The NI-DAQmx Base Readme lists which devices are supported by this
version of NI-DAQmx Base. In Windows, select Start»All Programs»
National Instruments»NI-DAQmx Base»DAQmx Base Readme.
The NI-DAQmx Base VI Reference Help contains VI reference and general
information about measurement concepts. In LabVIEW, select
Help»NI-DAQmx Base VI Reference Help.
The NI-DAQmx Base C Reference Help contains C reference and general
information about measurement concepts. In Windows, select Start»All
Programs»National Instruments»NI-DAQmx Base»Documentation»
C Function Reference Help.
Note All NI-DAQmx Base documentation for Linux is installed at /usr/local/
natinst/nidaqmxbase/documentation.
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Note All NI-DAQmx Base documentation for Mac OS X is installed at
/Applications/National Instruments/NI-DAQmx Base/documentation.

Training Courses
If you need more help getting started developing an application with
NI products, NI offers training courses. To enroll in a course or obtain
a detailed course outline, refer to ni.com/training.

Technical Support on the Web
For additional support, refer to ni.com/support or zone.ni.com.

Installing the Software
Software support for the NI USB-6008/6009 for Windows Vista/XP/2000
is provided by NI-DAQmx. The DAQ Getting Started Guide, which you
can download at ni.com/manuals, offers NI-DAQmx users step-by-step
instructions for installing software and hardware, configuring channels and
tasks, and getting started developing an application.
Note For information about non-Windows operating system support, refer to ni.com/
info and enter BaseGSGML.

Installing Other Software
If you are using other software, refer to the installation instructions that
accompany your software.

Example Programs
The NI-DAQmx CD contains example programs that you can use to get
started programming with the NI USB-6008/6009. Refer to the NI-DAQmx
for USB Devices Getting Started Guide that shipped with your device, and
is also accessible from Start»All Programs»National Instruments»
NI-DAQ, for more information.
The NI-DAQmx Base software ships with example programs you can use
to get started programming with the NI USB-6008/6009. Refer to the
NI-DAQmx Base Getting Started Guide that shipped with your device, and
is also accessible from Start»All Programs»National Instruments»
NI-DAQmx Base»Examples, for more information.
Note For information about non-Windows operating system support, refer to
ni.com/info and enter BaseGSGML.
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Installing the NI USB-6008/6009 Device
Before installing the device, you must install the software you plan to use
with the device. Refer to the Installing the Software section of this guide
and the documentation included with the software for more information.

External
Power
Supply

Vbus

+5 V/200 mA

PFI 0

USB

USB Microcontroller

P1.<0..3>
P0.<0..7>

Digital I/O Terminal Block

Full-Speed USB Interface

Figure 4 shows key functional components of the NI USB-6008/6009.

+2.5 V/CAL

SPI

AI <0..7>

12b DAC

AO 0

12b DAC

AO 1

Analog I/O Terminal Block

8 Channel
12/14b ADC

Figure 4. Device Block Diagram

Setting Up the NI USB-6008/6009 Device
Complete the following steps to set up the NI USB-6008/6009:
1.

Install combicon screw terminal blocks by inserting them into the
combicon jacks.
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2.

Figure 5 illustrates the signal labels that ship in the NI USB-6008/6009
kit. You can apply the signal labels to the screw terminal blocks for
easy signal identification.

3
or
4
1

ANALOG

DIGITAL

2

1
2

Terminal Number Labels (Use Both Together)
Digital I/O Label

3
4

Differential Signal Name Label (Use Either)
Single-Ended Signal Name Label (Use Either)

Figure 5. NI USB-6008/6009 Signal Labels

3.

Refer to Table 4 and Figures 5 and 6 for signal label orientation and
affix the provided signal labels to the screw terminal blocks. Until the
signal labels are applied, you can insert the screw terminal blocks into
either of the combicon jacks.
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Figure 6. Signal Label Application Diagram
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Once you label the screw terminal blocks, you must only insert them into the
matching combicon jack, as indicated by the overlay label on the NI USB-6008/6009
device.

Note

4.

Connect the wiring to the appropriate screw terminals.

Connecting the NI USB-6008/6009 to a Computer
Plug one end of the USB cable into the NI USB-6008/6009 and the other
end into an available USB port on the computer.

LED Indicator
The NI USB-6008/6009 device has a green LED next to the USB
connector. The LED indicator indicates device status, as listed in Table 3.
When the device is connected to a USB port, the LED blinks steadily to
indicate that the device is initialized and is receiving power from the
connection.
If the LED is not blinking, it may mean that the device is not initialized or
the computer is in standby mode. In order for the device to be recognized,
the device must be connected to a computer that has NI-DAQmx installed
on it. If your device is not blinking, make sure your computer has the latest
version of NI-DAQmx installed on it, and the computer is not in standby
mode.
Table 3. LED State/Device Status

LED State

Device Status

Not lit

Device not connected or in suspend.

On, not blinking

Device connected.

Single-blink

Operating normally.

I/O Connector
The NI USB-6008/6009 ships with one detachable screw terminal block for
analog signals and one detachable screw terminal block for digital signals.
These terminal blocks provide 16 connections that use 16 AWG to
28 AWG wire.
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Table 4 lists the analog terminal assignments, and Table 5 lists the digital
terminal assignments.
Table 4. Analog Terminal Assignments

Module

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16
© National Instruments Corporation

Terminal

Signal,
Single-Ended Mode

Signal,
Differential Mode

1

GND

GND

2

AI 0

AI 0+

3

AI 4

AI 0–

4

GND

GND

5

AI 1

AI 1+

6

AI 5

AI 1–

7

GND

GND

8

AI 2

AI 2+

9

AI 6

AI 2–

10

GND

GND

11

AI 3

AI 3+

12

AI 7

AI 3–

13

GND

GND

14

AO 0

AO 0

15

AO 1

AO 1

16

GND

GND

13
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Table 5. Digital Terminal Assignments

32 31 30 29 28 27 26 25 24 23 22 21 20 19 18 17

Module
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Terminal

Signal

17

P0.0

18

P0.1

19

P0.2

20

P0.3

21

P0.4

22

P0.5

23

P0 6

24

P0.7

25

P1.0

26

P1.1

27

P1.2

28

P1.3

29

PFI 0

30

+2.5 V

31

+5 V

32

GND

ni.com

Signal Descriptions
Table 6 describes the signals available on the I/O connectors.
Table 6. Signal Descriptions

Signal Name

Reference

Direction

Description

—

—

Ground—The reference point for the
single-ended AI measurements, bias
current return point for differential mode
measurements, AO voltages, digital
signals at the I/O connector, +5 VDC
supply, and the +2.5 VDC reference.

GND

AI <0..7>

Varies

Input

Analog Input Channels 0 to 7—For
single-ended measurements, each signal is
an analog input voltage channel. For
differential measurements, AI 0 and AI 4
are the positive and negative inputs of
differential analog input channel 0.
The following signal pairs also form
differential input channels:
<AI 1, AI 5>, <AI 2, AI 6>, and
<AI 3, AI 7>.

AO 0

GND

Output

Analog Channel 0 Output—Supplies the
voltage output of AO channel 0.

AO 1

GND

Output

Analog Channel 1 Output—Supplies the
voltage output of AO channel 1.

P1.<0..3>
P0.<0..7>

GND

Input or
Output

Digital I/O Signals—You can
individually configure each signal as an
input or output.

+2.5 V

GND

Output

+2.5 V External Reference—Provides a
reference for wrap-back testing.

+5 V

GND

Output

+5 V Power Source—Provides +5 V
power up to 200 mA.

PFI 0

GND

Input

PFI 0—This pin is configurable as either a
digital trigger or an event counter input.
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Analog Input
You can connect analog input signals to the NI USB-6008/6009 through
the I/O connector. Refer to Table 6 for more information about connecting
analog input signals.

Analog Input Circuitry
Figure 7 illustrates the analog input circuitry of the NI USB-6008/6009.

+2.5 VREF

30.9 kΩ

MUX

PGA

ADC

AI FIFO

127 kΩ
AI
39.2 kΩ

Input Range
Selection

Figure 7. Analog Input Circuitry

MUX
The NI USB-6008/6009 has one analog-to-digital converter (ADC).
The multiplexer (MUX) routes one AI channel at a time to the PGA.

PGA
The progammable-gain amplifier provides input gains of 1, 2, 4, 5, 8,
10, 16, or 20 when configured for differential measurements and gain
of 1 when configured for single-ended measurements. The PGA gain
is automatically calculated based on the voltage range selected in the
measurement application.

A/D Converter
The analog-to-digital converter (ADC) digitizes the AI signal by
converting the analog voltage into a digital code.
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AI FIFO
The NI USB-6008/6009 can perform both single and multiple A/D
conversions of a fixed or infinite number of samples. A first-in-first-out
(FIFO) buffer holds data during AI acquisitions to ensure that no data
is lost.

Analog Input Modes
You can configure the AI channels on the NI USB-6008/6009 to take
single-ended or differential measurements. Refer to Table 6 for more
information about I/O connections for single-ended or differential
measurements.

Connecting Differential Voltage Signals
For differential signals, connect the positive lead of the signal to the
AI+ terminal, and the negative lead to the AI– terminal.

AI+

Voltage
Source

NI USB-6008/6009

AI–

Figure 8. Connecting a Differential Voltage Signal

The differential input mode can measure ±20 V signals in the ±20 V range.
However, the maximum voltage on any one pin is ±10 V with respect to
GND. For example, if AI 1 is +10 V and AI 5 is –10 V, then the
measurement returned from the device is +20 V.

© National Instruments Corporation
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20
15
Amplitude (V)

10
5

AI 1
AI 5
Result

0
–5

–10
–15
–20

Figure 9. Example of a Differential 20 V Measurement

Connecting a signal greater than ±10 V on either pin results in a clipped
output.

20
15
Amplitude (V)

10
5

AI 1
AI 5
Result

0
–5

–10
–15
–20

Figure 10. Exceeding ±10 V on AI Returns Clipped Output

Connecting Referenced Single-Ended Voltage
Signals
To connect referenced single-ended voltage signals (RSE) to the
NI USB-6008/6009, connect the positive voltage signal to the desired
AI terminal, and the ground signal to a GND terminal, as illustrated in
Figure 11.
When no signals are connected to the analog input terminal, the internal
resistor divider may cause the terminal to float to approximately 1.4 V
when the analog input terminal is configured as RSE. This behavior is
normal and does not affect the measurement when a signal is connected.
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AI

Voltage
Source

NI USB-6008/6009

GND

Figure 11. Connecting a Referenced Single-Ended Voltage Signal

Digital Trigger
When an AI task is defined, you can configure PFI 0 as a digital trigger
input. When the digital trigger is enabled, the AI task waits for a rising or
falling edge on PFI 0 before starting the acquisition. To use ai/Start Trigger
with a digital source, specify PFI 0 as the source and select rising or falling
edge.

Analog Output
The NI USB-6008/6009 has two independent AO channels that can
generate outputs from 0–5 V. All updates of AO lines are software-timed.

Analog Output Circuitry
Figure 12 illustrates the analog output circuitry for the NI USB-6008/6009.

+5 V

REF(+) REF(–)
12-Bit
DAC

Output
Buffer

50 Ω
AO

GND

Figure 12. Analog Output Circuitry
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DACs
Digital-to-analog converts (DACs) convert digital codes to analog
voltages.

Connecting Analog Output Loads
To connect loads to the NI USB-6008/6009, connect the positive lead of the
load to the AO terminal, and connect the ground of the load to a GND
terminal.

AO

Load

NI USB-6008/6009

GND

Figure 13. Connecting a Load

Minimizing Glitches on the Output Signal
When you use a DAC to generate a waveform, you may observe glitches in
the output signal. These glitches are normal; when a DAQ switches from
one voltage to another, it produces glitches due to released charges. The
largest glitches occur when the most significant bit of the DAC code
changes. You can build a lowpass deglitching filter to remove some of
these glitches, depending on the frequency and nature of the output signal.
Refer to ni.com/support for more information about minimizing
glitches.

Digital I/O
The NI USB-6008/6009 has 12 digital lines, P0.<0..7> and P1.<0..3>,
which comprise the DIO port. GND is the ground-reference signal for the
DIO port. You can individually program all lines as inputs or outputs.
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Digital I/O Circuitry
Figure 14 shows P0.<0..7> connected to example signals configured as
digital inputs and digital outputs. You can configure P1.<0..3> similarly.

+5 V
1

LED
P0.0
P0.1
P0.2
P0.3
P0.4
P0.5
P0.6
P0.7

LED
2
3

+5 V

TTL Signal

4

Switch

GND
I/O Connector

1
2
3
4

P0.0 configured as an open collector digital output driving an LED
P0.2 configured as an active drive digital output driving an LED
P0.4 configured as a digital input receiving a TTL signal from a gated invertor
P0.7 configured as a digital input receiving a 0 V or 5 V signal from a switch

Figure 14. Example of Connecting a Load

Exceeding the maximum input voltage ratings or maximum output ratings, which
are listed in the Specifications section, can damage the device and the computer. National
Instruments is not liable for any damage resulting from such signal connections.

Caution

Source/Sink Information
The default configuration of the NI USB-6008/6009 DIO ports is open
collector, allowing 5 V operation, with an onboard 4.7 kΩ pull-up resistor.
An external user-provided pull-up resistor can be added to increase the
source current drive up to a 8.5 mA limit per line as shown in Figure 15.
The NI USB-6009 ports can also be configured as active drive using the
NI-DAQmx API, allowing 3.3 V operation with a source/sink current limit
of ±8.5 mA. Refer to the NI-DAQmx Help for more information about how
to set the DIO configuration.
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+5 V

NI USB-6008/6009

+5 V
External
Pull-Up
Resistor

Re

Rp
4.7 kΩ Onboard Resistor
Port Pad

P0.0

Rl
Load

A

GND

Figure 15. Example of Connecting an External User-Provided Resistor

Complete the following steps to determine the value of the user-provided
pull-up resistor:
1.

Place an ammeter in series with the load.

2.

Place a variable resistor between the digital output line and the +5 V
supply.

3.

Adjust the variable resistor until the ammeter current reads as the
intended current. The intended current must be less than 8.5 mA.

4.

Remove the ammeter and variable resistor from your circuit.

5.

Measure the resistance of the variable resistor. The measured
resistance is the ideal value of the pull-up resistor.

6.

Select a static resistor value for your pull-up resistor that is greater than
or equal to the ideal resistance.

7.

Re-connect the load circuit and the pull-up resistor.
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I/O Protection
To protect the NI USB-6008/6009 against overvoltage, undervoltage, and
overcurrent conditions, as well as ESD events, you should avoid these fault
conditions by using the following guidelines:
•

If you configure a DIO line as an output, do not connect it to any
external signal source, ground signal, or power supply.

•

If you configure a DIO line as an output, understand the current
requirements of the load connected to these signals. Do not exceed
the specified current output limits of the DAQ device.
National Instruments has several signal conditioning solutions for
digital applications requiring high current drive.

•

If you configure a DIO line as an input, do not drive the line with
voltages outside of its normal operating range. The DIO lines have
a smaller operating range than the AI signals.

•

Treat the DAQ device as you would treat any static sensitive device.
Always properly ground yourself and the equipment when handling
the DAQ device or connecting to it.

Power-On States
At system startup and reset, the hardware sets all DIO lines to
high-impedance inputs. The DAQ device does not drive the signal high
or low. Each line has a weak pull-up resistor connected to it.

Static DIO
Each of the NI USB-6008/6009 DIO lines can be used as a static DI or
DO line. You can use static DIO lines to monitor or control digital signals.
All samples of static DI lines and updates of DO lines are software-timed.

Event Counter
You can configure PFI 0 as a source for a gated invertor counter input edge
count task. In this mode, falling-edge events are counted using a 32-bit
counter. For more information about event timing requirements, refer to the
Specifications section.

© National Instruments Corporation

23

NI USB-6008/6009 User Guide and Specifications

Reference and Power Sources
The NI USB-6008/6009 creates an external reference and supplies a power
source. All voltages are relative to COM unless otherwise noted.

+2.5 External References
The NI USB-6008/6009 creates a high-purity reference voltage supply for
the ADC using a multi-state regulator, amplifier, and filter circuit. You can
use the resulting +2.5 V reference voltage as a signal for self test.

+5 V Power Source
The NI USB-6008/6009 supplies a 5 V, 200 mA output. You can use this
source to power external components.
Note

While the device is in USB suspend, the output is disabled.

Specifications
The following specifications are typical at 25 °C, unless otherwise noted.

Analog Input
Converter type ........................................Successive approximation
Analog inputs..........................................8 single-ended, 4 differential,
software selectable
Input resolution
NI USB-6008...................................12 bits differential,
11 bits single-ended
NI USB-6009...................................14 bits differential,
13 bits single-ended
Max sampling rate (aggregate)1
NI USB-6008...................................10 kS/s
NI USB-6009...................................48 kS/s
AI FIFO ..................................................512 bytes
Timing resolution ...................................41.67 ns (24 MHz timebase)

1

System dependent.
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Timing accuracy..................................... 100 ppm of actual sample rate
Input range
Single-ended ................................... ±10 V
Differential...................................... ±20 V1, ±10 V, ±5 V, ±4 V,
±2.5 V, ±2 V, ±1.25 V, ±1 V
Working voltage..................................... ±10 V
Input impedance..................................... 144 kΩ
Overvoltage protection........................... ±35
Trigger source ........................................ Software or external digital
trigger
System noise2
Single-ended
±10 V range ............................. 5 mVrms
Differential
±20 V range............................. 5 mVrms
±1 V range ............................... 0.5 mVrms
Absolute accuracy at full scale, single-ended
Range

Typical at 25 °C (mV)

Maximum over Temperature (mV)

±10

14.7

138

Absolute accuracy at full scale, differential3

1

2
3

Range

Typical at 25 °C (mV)

Maximum over Temperature (mV)

±20

14.7

138

±10

7.73

84.8

±5

4.28

58.4

±4

3.59

53.1

±2.5

2.56

45.1

±20 V means that |AI+ – (AI–)| <= 20 V. However, AI+ and AI– must both be within ±10 V of GND. Refer to the Connecting
Differential Voltage Signals for more information.
System noise measured at maximum sample rate.
Input voltages may not exceed the working voltage range.
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Range

Typical at 25 °C (mV)

Maximum over Temperature (mV)

±2

2.21

42.5

±1.25

1.70

38.9

±1

1.53

37.5

Analog Output
Analog outputs........................................2
Output resolution ....................................12 bits
Maximum update rate .............................150 Hz, software-timed
Output range ...........................................0 to +5 V
Output impedance...................................50 Ω
Output current drive................................5 mA
Power-on state ........................................0 V
Slew rate .................................................1 V/μs
Short circuit current ................................50 mA
Absolute accuracy (no load) ...................7 mV typical,
36.4 mV maximum at full scale

Digital I/O
Digital I/O
P0.<0..7> .........................................8 lines
P1.<0..3> .........................................4 lines
Direction control.....................................Each channel individually
programmable as input or output
Output driver type
NI USB-6008...................................Open collector (open-drain)
NI USB-6009...................................Each channel individually
programmable as active drive
(push-pull) or open collector
(open-drain)
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Compatibility ......................................... TTL, LVTTL, CMOS
Absolute maximum voltage range ......... –0.5 to 5.8 V with respect to GND
Pull-up resistor ....................................... 4.7 kΩ to 5 V
Power-on state........................................ Input
Digital logic levels
Level
Input low voltage
Input high voltage
Input leakage current
Output low voltage (I = 8.5 mA)
Output high voltage
Active drive (push-pull), I = –8.5 mA
Open collector (open-drain), I = –0.6 mA, nominal
Open collector (open-drain), I = –8.5 mA, with external
pull-up resistor

Min

Max

Units

–0.3
2.0
—

0.8
5.8
50

V
V
μA

—

0.8

V

2.0
2.0
2.0

3.5
5.0
—

V
V
V

External Voltage
+5 V output (200 mA maximum) .......... +5 V typical, +4.85 V minimum
+2.5 V output (1 mA maximum) ........... +2.5 V typical
+2.5 V accuracy ..................................... 0.25% max
Reference temperature drift ................... 50 ppm/°C max

Counter
Number of counters................................ 1
Resolution .............................................. 32 bits
Counter measurements ........................... Edge counting (falling-edge)
Counter direction.................................... Count up
Pull-up resistor ....................................... 4.7 kΩ to 5 V
Maximum input frequency..................... 5 MHz
Minimum high pulse width .................... 100 ns
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Minimum low pulse width......................100 ns
Input high voltage ...................................2.0 V
Input low voltage ....................................0.8 V

Bus Interface
USB specification ...................................USB 2.0 Full-Speed
USB bus speed........................................12 Mb/s

Power Requirements
USB
4.10 to 5.25 VDC.............................80 mA typical, 500 mA max
USB suspend ...................................300 μA typical, 500 μA max

Physical Characteristics
Dimensions
Without connectors..........................6.35 cm × 8.51 cm × 2.31 cm
(2.50 in. × 3.35 in. × 0.91 in.)
With connectors...............................8.18 cm × 8.51 cm × 2.31 cm
(3.22 in. × 3.35 in. × 0.91 in.)
I/O connectors.........................................USB series B receptacle,
(2) 16 position terminal block
plug headers
Weight
With connectors...............................84 g (3 oz)
Without connectors..........................54 g (1.9 oz)
Screw-terminal wiring ............................16 to 28 AWG
Torque for screw terminals.....................0.22–0.25 N · m
(2.0–2.2 lb · in.)
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Safety
If you need to clean the module, wipe it with a dry towel.

Safety Voltages
Connect only voltages that are within these limits.
Channel-to-GND .................................... ±30 V max,
Measurement Category I
Measurement Category I is for measurements performed on circuits not
directly connected to the electrical distribution system referred to as
MAINS voltage. MAINS is a hazardous live electrical supply system that
powers equipment. This category is for measurements of voltages from
specially protected secondary circuits. Such voltage measurements include
signal levels, special equipment, limited-energy parts of equipment,
circuits powered by regulated low-voltage sources, and electronics.
Do not use this module for connection to signals or for measurements within
Measurement Categories II, III, or IV.

Caution

Safety Standards
This product is designed to meet the requirements of the following
standards of safety for electrical equipment for measurement, control,
and laboratory use:

Note

•

IEC 61010-1, EN 61010-1

•

UL 61010-1, CSA 61010-1

For UL and other safety certifications, refer to the product label or visit

ni.com/certification, search by model number or product line, and click the

appropriate link in the Certification column.

Hazardous Locations
The NI USB-6008/6009 device is not certified for use in hazardous
locations.
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Environmental
The NI USB-6008/6009 device is intended for indoor use only.
Operating temperature
(IEC 60068-2-1 and IEC 60068-2-2)......0 to 55 °C
Operating humidity
(IEC 60068-2-56) ...................................5 to 95% RH, noncondensing
Maximum altitude...................................2,000 m (at 25 °C ambient
temperature)
Storage temperature
(IEC 60068-2-1 and IEC 60068-2-2)......–40 to 85 °C
Storage humidity
(IEC 60068-2-56) ..................................5 to 90% RH, noncondensing
Pollution Degree (IEC 60664) ................2

Electromagnetic Compatibility
This product is designed to meet the requirements of the following
standards of EMC for electrical equipment for measurement, control,
and laboratory use:

Note

•

EN 61326 EMC requirements; Minimum Immunity

•

EN 55011 Emissions; Group 1, Class A

•

CE, C-Tick, ICES, and FCC Part 15 Emissions; Class A

For EMC compliance, operate this device with double-shielded cables.

CE Compliance
This product meets the essential requirements of applicable European
Directives, as amended for CE marking, as follows:
•

2006/95/EC; Low-Voltage Directive (safety)

•

2004/108/EC; Electromagnetic Compatibility Directive (EMC)

Refer to the Declaration of Conformity (DoC) for this product for any additional
regulatory compliance information. To obtain the DoC for this product, visit
ni.com/certification, search by module number or product line, and click the
appropriate link in the Certification column.
Note
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Environmental Management
National Instruments is committed to designing and manufacturing
products in an environmentally responsible manner. NI recognizes that
eliminating certain hazardous substances from our products is beneficial
not only to the environment but also to NI customers.
For additional environmental information, refer to the NI and the
Environment Web page at ni.com/environment. This page contains the
environmental regulations and directives with which NI complies, as well
as other environmental information not included in this document.

Waste Electrical and Electronic Equipment (WEEE)
EU Customers At the end of their life cycle, all products must be sent to a WEEE recycling
center. For more information about WEEE recycling centers and National Instruments
WEEE initiatives, visit ni.com/environment/weee.htm.

⬉ᄤֵᙃѻક∵ᶧࠊㅵ⧚ࡲ⊩ ˄Ё RoHS˅
Ёᅶ᠋ National Instruments ヺড়Ё⬉ᄤֵᙃѻકЁ䰤ࠊՓ⫼ᶤѯ᳝ᆇ⠽䋼ᣛҸ (RoHS)Ǆ
݇Ѣ National Instruments Ё RoHS ড়㾘ᗻֵᙃˈ䇋ⱏᔩ ni.com/environment/rohs_chinaǄ
(For information about China RoHS compliance, go to ni.com/environment/rohs_china.)

Where to Go for Support
The National Instruments Web site is your complete resource for technical
support. At ni.com/support you have access to everything from
troubleshooting and application development self-help resources to email
and phone assistance from NI Application Engineers.
National Instruments corporate headquarters is located at
11500 North Mopac Expressway, Austin, Texas, 78759-3504.
National Instruments also has offices located around the world to help
address your support needs. For telephone support in the United States,
create your service request at ni.com/support and follow the calling
instructions or dial 512 795 8248. For telephone support outside the United
States, contact your local branch office:
Australia 1800 300 800, Austria 43 662 457990-0,
Belgium 32 (0) 2 757 0020, Brazil 55 11 3262 3599,
Canada 800 433 3488, China 86 21 5050 9800,
Czech Republic 420 224 235 774, Denmark 45 45 76 26 00,
Finland 358 (0) 9 725 72511, France 01 57 66 24 24,
Germany 49 89 7413130, India 91 80 41190000, Israel 972 3 6393737,
Italy 39 02 41309277, Japan 0120-527196, Korea 82 02 3451 3400,

© National Instruments Corporation

31

NI USB-6008/6009 User Guide and Specifications

Lebanon 961 (0) 1 33 28 28, Malaysia 1800 887710,
Mexico 01 800 010 0793, Netherlands 31 (0) 348 433 466,
New Zealand 0800 553 322, Norway 47 (0) 66 90 76 60,
Poland 48 22 3390150, Portugal 351 210 311 210, Russia 7 495 783 6851,
Singapore 1800 226 5886, Slovenia 386 3 425 42 00,
South Africa 27 0 11 805 8197, Spain 34 91 640 0085,
Sweden 46 (0) 8 587 895 00, Switzerland 41 56 2005151,
Taiwan 886 02 2377 2222, Thailand 662 278 6777,
Turkey 90 212 279 3031, United Kingdom 44 (0) 1635 52354

National Instruments, NI, ni.com, and LabVIEW are trademarks of National Instruments Corporation.
Refer to the Terms of Use section on ni.com/legal for more information about National
Instruments trademarks. Other product and company names mentioned herein are trademarks or trade
names of their respective companies. For patents covering National Instruments products, refer to the
appropriate location: Help»Patents in your software, the patents.txt file on your CD, or
ni.com/patents.
© 2004–2008 National Instruments Corporation. All rights reserved.
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